OpenAthens LA support will end on 31 March 2020

Search

Skip to end of metadata
Go to start of metadata

When you're updating you may encounter yum errors referring to libmemcached.

To resolve:

  1. Using your text editor of choice, update the openathens.repo file to exclude libmemcached from our repo.

    sudo nano /etc/yum.repos.d/openathens.repo
    [openathens-la]
    name = yum repository for athens rpms
    baseurl = https://yourusername:yourpassword@repo.openathens.net/yum/pkgs/rhel$releasever/la/2.2/$basearch
    enabled = 1 
    gpgcheck = 0
    failovermethod = priority
    #This line will address the libmemcached issue.
    exclude = libmemcached
  2. Save and then remove the existing libmemcached. This will also remove the OpenAthens LA component

    sudo yum erase libmemcached
  3. Now re-install the OpenAthens LA component

    sudo yum install openathensla-runtime
    sudo yum install openathensla-proxy

This will now use a maintained version of libmemcached and cause no more dependency problems.

Anything to watch out for?

Steps 2 and 3 will take the runtime out of operation for a few minutes which may be a consideration if you have a single runtime in production.

  • No labels